Results 1 to 4 of 4

Thread: Downgrade 4.1 to 4.01

  
  1. #1
    joj141 is offline -Hacks Newbie
    Join Date
    Oct 2010
    Posts
    5
    Rep Power
    0

    Default

    I have a 3 month-old 3GS (with new bootrom) that was never jailbroken or unlocked. But it is upgraded to iOS 4.1. I want to downgrade it to 4.01 and then do JB and unlock. Lot of help on-line for that! I put it into DMU mode and then used iTunes option+restore and browsed to this file: iPhone2,1_4.0.1_8A306_Restore.ipsw. Itunes verifies it and then tells me that I cannot restore to this firmware, "the device isn't eligible for the requested build."

    Okay, I read how to change the host file to make it look somewhere else for verification. But that was for those who had jailbroken theirs previously and it was to get the shsh stuff from Cydia to make it downgradable.

    So, even though I do not need to restore shsh files, do I still need to do that to get iTunes to accept the older firmware again?

    Thanks to anyone who can advise me. JoJ


  2. #2
    Kevmau5's Avatar
    Kevmau5 is offline God to All Mod -Hacks Guru
    Join Date
    Mar 2009
    Location
    A Box
    Posts
    1,715
    Rep Power
    0

    Default

    to downgrade you need your shsh's for 4.0.1 saved.

    and since your phone was never jailbroken or unlocked previously ( im assuming they were not saved by tiny umbrella on your pc/mac) then you do nt have ANY shsh's saved.

    there is nothing for you at this very moment

    you'll have to wait a little longer till SHAtter is released.

    :(
    http://s1218.photobucket.com/albums/dd401/Kevmau5/?action=view&current=JB.jpg&newest=1

  3. #3
    imported_hobo is offline -Hacks Newbie
    Join Date
    Oct 2010
    Posts
    1
    Rep Power
    0

    Default

    Your 3GS can be downgraded and jailbroken if you have the old bootrom.
    http://www.redmondpie.com/how-to-jai...agetool-guide/

  4. #4
    joj141 is offline -Hacks Newbie
    Join Date
    Oct 2010
    Posts
    5
    Rep Power
    0

    Default

    Thanks for answer to save me trying and trying. Why can't I use a "general" shsh created for generic useage? I mean, for an identical iphone with same bootrom, baseband etc?

    Too bad I have the new bootrom. I will keep on waiting!..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •