Results 1 to 6 of 6

Thread: Cant get one dang image to load

  
  1. #1
    JoshF is offline -Hacks Newbie
    Join Date
    Mar 2006
    Posts
    12
    Rep Power
    0

    Default

    Can anyone point me in the right direction.

    I can't even get one image to load using LUA. I have looked at different codes and have not been able to get images to load from my program or even other people's programs. Can anyone please post code that will surely display a picture (any type) That would be very helpful.


  2. #2
    soulkiller is offline -Hacks Smarty
    Join Date
    Jan 2006
    Location
    pffff I\'m not telling you
    Posts
    197
    Rep Power
    14

    Default

    well thats not hard

    Code:
    picture = Image.load("picture.png")
    while true do
         screen.clear()
         screen:blit(0,0,picture)
         screen.flip()
         screen.waitVblankStart()
    end
    place a .png type picture file named PICTURE in the same folder as your script.


    Its possible that its lua what version do you have? if its below the latest (at the time of writing its .16 ) get the newest one and try or maybe just try downloading lua again maybe the one you downloaded was corrupted (very unlikely) if your running your lua apps with either the windows version of lua player or one thats compiled with a hombrew ex: File Assistant++. I wouldn't recommend it, first try with the regular latest version of luaplayer then try others. hope this helps :bucktooth:
    GOOGLE IS YOUR FREIND, USE IT. IF GOOGLE FAILS THEN REFER TO THIS LINK MQ:BtG Programmer

  3. #3
    JoshF is offline -Hacks Newbie
    Join Date
    Mar 2006
    Posts
    12
    Rep Power
    0

    Default

    I just tested this and it DOESN"T work with the LUA player for windows. I am using the Windows EXE file to compile the code. Is that wrong? Should I be using something else?

    I know that code is right, but why won't the image load?

  4. #4
    soulkiller is offline -Hacks Smarty
    Join Date
    Jan 2006
    Location
    pffff I\'m not telling you
    Posts
    197
    Rep Power
    14

    Default

    Ya don't use the windows version I got it to work ONCE with lots of tweaking. its not worth it until they release a later version just use the version for psp for know (as for my tweaked version of windows lua player it is gone)
    GOOGLE IS YOUR FREIND, USE IT. IF GOOGLE FAILS THEN REFER TO THIS LINK MQ:BtG Programmer

  5. #5
    JoshF is offline -Hacks Newbie
    Join Date
    Mar 2006
    Posts
    12
    Rep Power
    0

    Default

    crap, well that's my problem. That's very inefficient cause I have firmware 2.60 and I would have to load up GTA just to test something. Thats ridiculous. Does anyone else have any suggestions?

    edit, and does pad= Controls.read() work on windows lua??

  6. #6
    bob joe is offline -Hacks Smarty
    Join Date
    Feb 2006
    Posts
    188
    Rep Power
    14

    Default

    let me see the pictures youre using. if any of them is more than 512x512 or isnt in any of the supported formats (jpg, png, and tga), than it wont work.
    Are you in good hands?

    Try using the PSP Upgrader/Downgrader
    http://www.psp-hacks.com/forums/viewtopic.php?id=101827

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •