Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: GTA Liberty City Stories... Where do I stand Legally?

  
  1. #1
    phOny is offline -Hacks Newbie
    Join Date
    Nov 2005
    Posts
    1
    Rep Power
    0

    Default

    Okay, PSP arrived yesterday and I bought this game, My PSP has 1.50 firmware and after loading the game i realise it needs 2.0 firmware. The firmware upgrade is on the disk but i dont a) want to upgrade firmware and b) dont feel i should be bullied into it. I was wondering where I stand legally as nowhere on the case does it say that owners for firmware lower than 2.0 will need to upgrade to play it. This is now a waste of money to the tune of £33 and im pretty annoyed at the moment... can i take it back to the store and be within my rights to demand a refund as it doesnt state that it wont work with 1.50?


  2. #2
    p4ch3c0 is offline Senior Member -Hacks Titan
    Join Date
    Sep 2005
    Posts
    3,720
    Rep Power
    18

    Default

    I never though of that... Hmm... :?

  3. #3
    Razalom is offline -Hacks Newbie
    Join Date
    Nov 2005
    Posts
    14
    Rep Power
    0

    Default

    Its at least worth a go taking it back. If I had bought it I would take it back.

  4. #4
    Alex187 is offline -Hacks Neophyte
    Join Date
    Oct 2005
    Posts
    61
    Rep Power
    14

    Default

    Luckily you live in the UK, and we have laws:

    Your rights when shopping - buying goods

    The law says that goods must be:

    ...fit for their purposes, including any particular purpose mentioned by you to the seller – for example, if you are buying a computer game and you explain you want one that can be played on a particular machine, the seller must not give you a game that cannot be played on that machine
    as described - on the package or a display sign, or by the seller. If you are told that a shirt is 100% cotton, then it should not turn out to be cotton and polyester...
    http://www.oft.gov.uk/Consumer/Your+...ying+goods.htm

    Where did you buy it from? Most retailers will at least let you exchange it for another game

  5. #5
    shuman is offline -Hacks Newbie
    Join Date
    Nov 2005
    Posts
    5
    Rep Power
    0

    Default

    I was having the same problem with Burnout : Legends. all you have to do is go to the

    Download section on this site

    Then PSPHomebrew

    Then Misc. Apps & Tools

    http://www.psp-hacks.com/category/21/

    and download the PSPset file. In this application you can let it patch your firmware from 1.00 to 1.50 to 1.52 to 2.00 you just select "set version 2.00"
    and then quit the application and then the game works. thats how easy it was for me. no problems at all. hope this helps

    P.S. for safe downgrade from 2.00 to 1.50 go to
    [url=http://www.hackaday.com/entry/1234000687060851/]http://www.hackaday.com/entry/1234000687060851/

  6. #6
    sco2001 is offline -Hacks Newbie
    Join Date
    Aug 2005
    Posts
    2
    Rep Power
    0

    Default

    that doesnt work for gta mate

  7. #7
    Spartan 117's Avatar
    Spartan 117 is offline Senior Member -Hacks Titan
    Join Date
    May 2005
    Location
    Woodbridge, Virginia
    Posts
    7,847
    Rep Power
    48

    Default

    or Socom :cry:
    lol @ Thread

    © Spartan 117. 2005-2019. All rights Reserved, lol

    Need X-Box 360 help, Click Here!

  8. #8
    shuman is offline -Hacks Newbie
    Join Date
    Nov 2005
    Posts
    5
    Rep Power
    0

    Default

    gotta do it the hard way then and any time you want to use homebrew gotta overflow and then downgrade and any time u want to play a new game update to 2.00 that comes with GTA :cry:

  9. #9
    barnes8 is offline -Hacks Enthusiast
    Join Date
    Nov 2005
    Posts
    444
    Rep Power
    14

    Default

    I whoudnt Update with the GTA disc, theres rumors around that you cant downgrade. I sugest get the EBOOT from this site to be safe.

  10. #10
    shuman is offline -Hacks Newbie
    Join Date
    Nov 2005
    Posts
    5
    Rep Power
    0

    Default

    rumor...i wish. i got gta today and decided to update figuring since they released a 2.01 that the 2.00 with the game was safe... it wasn't. overflow won't work. sony got me...for now.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •