Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25

Thread: Downgrade? No thanks. I'll keep v2.0

  
  1. #1
    Vizzy is offline -Hacks Newbie
    Join Date
    Sep 2005
    Posts
    8
    Rep Power
    0

    Default

    With all the talk about downgrading the firmware, I thought I'd add an opinion, and here it is: 2.0 is better than 1.5, and I wouldn't downgrade my psp even if I could. :-)

    The new web browser in 2.0 is cool.
    The new AVC video quality in 2.0 is sweet.
    Sending photos over wi-fi to another psp is awesome. :-)

    And it's just good to have the latest official version of an OS.

    Sure, Homebrew is awesome. I wish it could work on 2.0, but it doesn't. So I would prefer to wait for someone to hack 2.0 so homebrew works on that... or... perhaps Im wrong and I should understand that 1.5 homebrew can bring V 2.0 features anyway... :-)


  2. #2
    Jaxx is offline Senior Member -Hacks Enthusiast
    Join Date
    Aug 2005
    Posts
    539
    Rep Power
    15

    Default

    2 words: no homebrew

  3. #3
    Exira is offline -Hacks Guru
    Join Date
    Jun 2005
    Posts
    1,976
    Rep Power
    16

    Default

    yeah a downgrader realy is a half assed idea.
    its a middle ground though, but I have my own web browser plus I play psp games for free. :mrgreen:
    Oh come let us adore him, betray, and then ignore him.

  4. #4
    norezon4aname is offline -Hacks Neophyte
    Join Date
    Aug 2005
    Posts
    54
    Rep Power
    15

    Default

    firmware 1.50 can have the same stuff that firmware 2.0 has. they have a web browser for 1.50, they have a program that can change the background of the psp, is called homebrew! and just to tell u, if they successfully downgrade 2.0, then all you have to do is downgrade to 1.50 to play around with homebrew and if you get tired of it just update back to 2.0! :lol:
    (Its Kinda BS That The Downgrader Didn\'t Come out on Sept.1)

  5. #5
    qwerty is offline Senior Member -Hacks Veteran
    Join Date
    Jun 2005
    Location
    Texas
    Posts
    1,281
    Rep Power
    16

    Default

    ive tried firmware 2. it isnt that great

    PSP 5.00 m33

  6. #6
    norezon4aname is offline -Hacks Neophyte
    Join Date
    Aug 2005
    Posts
    54
    Rep Power
    15

    Default

    I had PSP firmware 2.0 too and I dont like it at all. the browser is limited and all they added was more security and a background changer. wupy!
    (Its Kinda BS That The Downgrader Didn\'t Come out on Sept.1)

  7. #7
    Jaxx is offline Senior Member -Hacks Enthusiast
    Join Date
    Aug 2005
    Posts
    539
    Rep Power
    15

    Default

    i have 2.0 it bs

  8. #8
    EleMenT is offline -Hacks Enthusiast
    Join Date
    Jun 2005
    Location
    Minneapolis, Minnesota
    Posts
    366
    Rep Power
    15

    Default

    2.0 is shit. I'd give anything for 1.5. I upgraded my psp the day after i got it to version 1.51. Then i joined these forums and they were talking about hacking 1.5.. >_<

  9. #9
    XanderChaos is offline -Hacks Smarty
    Join Date
    May 2005
    Location
    Florida
    Posts
    197
    Rep Power
    15

    Default

    Meh, I don't care for homebrew that much. The only emu I would use is the VBA, which apparently doesn't go that fast. MY dad would kidnap my PSP to play Dr. Mario on it. I have tried loads of homebrew on my friend's PSP and don't like any. Then only thing I would use it for would be to play ISO's.

    On the other hand, I like the web browser, cause I can go online after I go to bed nd I wont get caught.
    _________________

  10. #10
    RaiderX's Avatar
    RaiderX is offline Senior Member -Hacks Titan
    Join Date
    Jun 2005
    Posts
    4,192
    Rep Power
    21

    Default

    well, I ahve a 2.0 and a 1.5 and i love my homebrew, but this is from a guy who lovers all the old games and Ive got dozens of SNES, NES, GBC, Genseis games!! I love it more than my 2.0, but its ok. a downgrader is half-assed, but its getting sumwhere, ad if u wanted to, u coudl use ur 32 meg crapstick to hold the 2.0 upgrade anmd the 1.5 downgrade and use them on the go

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •