Results 1 to 5 of 5

Thread: Medievil Resurrection : Requires Upgrade

  
  1. #1
    RyuKisargi is offline -Hacks Newbie
    Join Date
    Jul 2005
    Posts
    3
    Rep Power
    0

    Default

    I dunoo if any of you have heard this, but the US just released Medievil Resurrection.

    It requres a 1.52 PSP.

    It also has the 1.52 update on the PSP.

    Is this the first game that requires it? Quite likely.

    And there's damn well more to come.


  2. #2
    tntpsp is offline -Hacks Neophyte
    Join Date
    Aug 2005
    Location
    L.A
    Posts
    81
    Rep Power
    15

    Default

    now I understand why gt4 is taking so long to come out I think that gtame as well as gand theft auto will have 2.0 firmwhere
    dont like bull shit

  3. #3
    minsin is offline -Hacks Smarty
    Join Date
    Aug 2005
    Location
    New York, Queens
    Posts
    159
    Rep Power
    15

    Default

    get the WAb-firmware changer
    it will make the game THINK that you have 2.0 or 1,51 whatever.
    You can get it at the download page of this site.
    How much wood would a woodchuck chuck if a woodchuck would chuck wood? thks Raiderx and FWD 2.0 exploit

  4. #4
    Mitwang is offline -Hacks Guru
    Join Date
    Jun 2005
    Location
    In The Tree Behind Your Window
    Posts
    2,470
    Rep Power
    17

    Default

    or download the iso after you buy the game

    Brothers In Arms
    VISIT THE F.A.Q BEFORE YOU POST IN THE HELP SECTION!

  5. #5
    Eclipse9069 is offline -Hacks Neophyte
    Join Date
    Jul 2005
    Posts
    62
    Rep Power
    15

    Default

    Burnout Legends requires 1.52.

    I just used WAB Firmware Changer to change my psp to 2.0 :E

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •