Results 1 to 5 of 5

Thread: Got my PSP today

  
  1. #1
    excessive is offline -Hacks Newbie
    Join Date
    Oct 2005
    Posts
    28
    Rep Power
    0

    Default

    Got my PSP today (in the UK). After charging it up and powering it on, it was firmware version 1.52. So I upgraded to 2.00 with the supplied UMD, then downgraded to 1.50, and it worked perfect. Been playing some Sega Genesis games tonight. I would be playing PSP games but the site i ordered from sent the 1gb memory card seperately from the PSP itself, so i'll have to wait til next week before i can do anything else :eek: . One thing i wasn't expecting though was after downgrading to 1.50 i thought UMD movies would still play, but the film i was supplied with (Donnie Darko) doesn't play, saying i need to upgrde the system software, which is quite annoying. Apart from that it's fine.

    Just want to say thanks for this site and the PSPtutorials.

    ExcessivE


  2. #2
    annulus k is offline -Hacks Neophyte
    Join Date
    Aug 2005
    Location
    Charlotte, NC
    Posts
    53
    Rep Power
    15

    Default

    Use the Wab Version Changer. It tricks your psp into thinking it has 2.0 installed on it, but it really doesn't. So once you use it, your movie should work.

    Current Firmware: 1.5 and 2.71 | Current Game: GTA: LCS

  3. #3
    belly0fdesire is offline Senior Member -Hacks God
    Join Date
    Sep 2005
    Location
    Southern California
    Posts
    3,252
    Rep Power
    18

    Default

    Yeah... you can find the WAB Version Changer in the downloads section here... and YAY!!!! YOU GOT A PSP!!!! .... welcome to the forum!!

  4. #4
    excessive is offline -Hacks Newbie
    Join Date
    Oct 2005
    Posts
    28
    Rep Power
    0

    Default

    Thanx for the info. I donwloaded WAB Changer 2.5 from the download section, but the UMD movie still doesn't run, and i had to reset the PSP because it froze trying to load it. :eek:

  5. #5
    dk138 is offline -Hacks Newbie
    Join Date
    Aug 2005
    Posts
    39
    Rep Power
    15

    Default

    downgraders scare me. my psp was born with 1.50.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •