So pspsetx allows you to "change" your firmware to 2.5. It seems some games require the actual 2.5. So what are some games that work with pspsetx, and what are some that don't work with it? What is it in 2.5 that these games require?