Results 1 to 5 of 5

Thread: Buying a PSP...What to do about the firmware version?

  
  1. #1
    Seraphic is offline -Hacks Enthusiast
    Join Date
    Feb 2006
    Posts
    330
    Rep Power
    14

    Default

    Hi,

    I'm looking to buy a Ceramic Japanese PSP.
    Most of the ones I’m finding are 2.0 or higher. And from what I can tell looking over the forums here it looks like you can do a lot of interesting things using a version 1.5.

    So my questions are...

    1. Will 2.0 or higher versions ever be able to do all the things a 1.5 can do?
    2. When Sony makes a PSP update are they are they mainly adding great new features or are they trying to make sure people can't use isos/homebrews?
    3. Is it foolish to keep a PSP up-to-date with the most current version?

    Thanks


  2. #2
    capnfuffy is offline -Hacks Veteran
    Join Date
    Feb 2006
    Location
    York, Pennsylvania
    Posts
    1,064
    Rep Power
    15

    Default

    1- 2.00 can be downgraded to 1.50 so if you can get ahold of a 2.00 your golden (keep in mind a jap. psp cannot play usa umd video)

    2- both - some new firmwares are only security addons (1.51, 1.52, 2.01)
    - some are features *and prolly some security as well* (2.00, 2.50, 2.60)

    3- if you want to purchase new game umd's, have the features of the new firmwares, then yes keeping it up to date would be the thing to do
    - if your looking to run alot of homebrew and iso files then your guna be staying at 1.50 and ignoring all the new firmwares as they come out

  3. #3
    Seraphic is offline -Hacks Enthusiast
    Join Date
    Feb 2006
    Posts
    330
    Rep Power
    14

    Default

    Quote Originally Posted by capnfuffy
    (keep in mind a jap. psp cannot play usa umd video)
    I found a few posts that say you can still play usa umd videos. But you have to move them to a memory stick and play them from there. That true?

    Quote Originally Posted by capnfuffy
    some are features *and prolly some security as well* (2.00, 2.50, 2.60)
    Isn't the web browser only available on version 2.1, or does it also work on 1.5?

  4. #4
    LeftEar is offline -Hacks Hacker
    Join Date
    Dec 2005
    Posts
    921
    Rep Power
    14

    Default

    The browser is available on 2.0+, but there are browsers that you can get that work on 1.5 like the fired up browser.

  5. #5
    capnfuffy is offline -Hacks Veteran
    Join Date
    Feb 2006
    Location
    York, Pennsylvania
    Posts
    1,064
    Rep Power
    15

    Default

    im not sure if you can watch ripped umd video or not
    never tryed it myself

    and the official sony web browser is on every firmware newer than 1.52 like LeftEar said
    fired up is the browser you want for 1.50 which is ripped directly from the games umd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •