Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31

Thread: How much longer do you think v1.5 can last?

  
  1. #1
    Jalard123 is offline -Hacks Newbie
    Join Date
    Apr 2006
    Posts
    34
    Rep Power
    14

    Default

    I have a feeling that soon all games won't be able to be run off memory sticks (already starting to happen with Outrun 2006), and we'll just be stuck with the older games unless we update. I'm keeping my 1.5. However, if the next GTA isn't able to be put onto a memory stick, that might be the end of my v1.5 (or I might just get a second PSP to update and play the newest games). By that time, everyone will update to the latest firmware, which will preobably be completely unhackable. I wish 1.5 could last forever, but Sony and the developers have been successful in outsmarting the hackers by getting n00bs to update to play the latest games. Soon after they update, they realize that they were being stupid, though. But....I just see the end of v1.5 (and possible homebrew) coming soon.


  2. #2
    drmadcow is offline Senior Member -Hacks Guru
    Join Date
    Oct 2005
    Location
    Hell, Michigan
    Posts
    1,513
    Rep Power
    15

    Default

    1.5 will last til sony releases another fw that you can run ISO's off of. Theres only a small handful of ISO's that can't be played yet but more and more of them are working and availible for free for 1.5 users.

    You can still buy 1.5,1.51,1.52,2.00 psp's for the same price as a 2.6 if you know where to look. 1.5 will last as long as people will want to use homebrew easy and get PSP games for free.

    People thought at first GTA:LC would never run on 1.5 and look what happened! 1.5 will be around as long as the psp itself is around and most likely will keep being the best firmware because anything thats new that comes out in FW updates can be duplicated on 1.5 in some way.

  3. #3
    Jalard123 is offline -Hacks Newbie
    Join Date
    Apr 2006
    Posts
    34
    Rep Power
    14

    Default

    Quote Originally Posted by drmadcow
    1.5 will last til sony releases another fw that you can run ISO's off of. Theres only a small handful of ISO's that can't be played yet but more and more of them are working and availible for free for 1.5 users.

    You can still buy 1.5,1.51,1.52,2.00 psp's for the same price as a 2.6 if you know where to look. 1.5 will last as long as people will want to use homebrew easy and get PSP games for free.

    People thought at first GTA:LC would never run on 1.5 and look what happened! 1.5 will be around as long as the psp itself is around and most likely will keep being the best firmware because anything thats new that comes out in FW updates can be duplicated on 1.5 in some way.
    Yeah, but look at Outrun 2006. It doesn't have the PRX files making it incapable of running of the memory stick. I'm sure more and more developers will start doing this, making the newest games unplayable on a v1.5.

  4. #4
    zero129 is offline -Hacks Enthusiast
    Join Date
    Mar 2006
    Posts
    324
    Rep Power
    14

    Default

    Well it seems to me the next big step in hacking the psp is custom fw that will allow us to boot 2.6+ games etc, so i'd say 1.5 will last till then.


    \"EA is like something that came right from star wars, they are the empire trying to take over all the small rebel game makers who stands in their way\".

  5. #5
    qwerty is offline Senior Member -Hacks Veteran
    Join Date
    Jun 2005
    Location
    Texas
    Posts
    1,281
    Rep Power
    16

    Default

    forever. case closed. close the thread.

    PSP 5.00 m33

  6. #6
    Staind is offline -Hacks Enthusiast
    Join Date
    Dec 2005
    Location
    Kansas City
    Posts
    417
    Rep Power
    14

    Default

    Quote Originally Posted by zero129
    Well it seems to me the next big step in hacking the psp is custom fw that will allow us to boot 2.6+ games etc, so i'd say 1.5 will last till then.
    I was thinking that too, or somehow they access kernal mode, or the ability to "overwrite" UMD's or something.

  7. #7
    contra24 is offline -Hacks Guru
    Join Date
    Dec 2005
    Location
    Middle East
    Posts
    1,691
    Rep Power
    15

    Default

    even if newer firmware released and 1.5 wasnt able to hack it games that wont make me upgrade, the games avaliable now for 1.50 is enough to keep this firmware, and if good games released on newer firmware buying another psp will be better than upgrading

    try my 3.03OE-A installer here it\'s the best
    P.S DONT PM ME ASKING WHERE TO GET PS1 GAMES FROM

  8. #8
    TheWebSlinger is offline -Hacks Enthusiast
    Join Date
    Mar 2006
    Location
    Daily Bugle
    Posts
    328
    Rep Power
    14

    Default

    come on guys have some faith, it wont be long before the games we cant play yet, will be hacked..

    Im mean just look there was GTA and everyone was like this game is impossible to hack,
    and im always playing it on my 1.5.

    And then there was sfa3, SFDM, worms etc..



    your friendly neighbourhood SpiderMan

  9. #9
    TheAceOfHearts's Avatar
    TheAceOfHearts is offline Senior Member -Hacks Guru
    Join Date
    Dec 2005
    Location
    Earth
    Posts
    2,079
    Rep Power
    17

    Default

    <--- 1.5 for life, when a better firmware comes out I will still keep 1.5, but I will buy another one :P.
    ssr
    killaj said: there is one answer to one simple question as to whether a girl is attractive or not. One all-inclusive, unbelievably powerful question that you must ask yourself to determine if you think a girl is hot or not. Do you know what that question is? "Would I hit it?"
    If your answer is "yes", then that's all you need to know. Hit that shit. If your answer is "no", then leave it be.
    Quote Originally Posted by Yoko
    Michael said (5:41 PM):
    it doesn't really it just helps soften the impact of my tremendous cock once i grab them from behind
    NewInfo2Day.Com

  10. #10
    sticky is offline Senior Member -Hacks Titan
    Join Date
    Dec 2005
    Location
    Singapore
    Posts
    4,341
    Rep Power
    18

    Default

    i will prolly buy a new psp (if possible ) if i saw that 1 year after crisis core came out and it is still not playable on 1.5. i just cant reisist the power of final fantasy games!!! argh!!!

    :::: [11th Squad Vice-Captain - Yachiru~!]::::

Page 1 of 4 1 2 3 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •