Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26

Thread: Convince me not to update!

  
  1. #1
    kleimey is offline -Hacks Newbie
    Join Date
    Apr 2006
    Posts
    2
    Rep Power
    0

    Default

    I have a 1.5 but I'm thinking of updating. I think I'll get more use out of my psp with a web browser. Plus I really want to play SFA3 and Daxter and save my progress. I played enough snes and nes games a decade ago, I'm looking for something else. What are the killer homebrew apps that I'm missing?


  2. #2
    cls
    cls is offline Senior Member -Hacks Guru
    Join Date
    Jun 2005
    Location
    the netherland Rank: Mod
    Posts
    1,782
    Rep Power
    16

    Default

    iso's daxter is playable with your own saves.sooo that is one point why not to update.
    emulators works best on 1.5
    a web browser is also avaible on 1.5 its a homebrew.

    so dont updated

  3. #3
    psychokill is offline -Hacks Veteran
    Join Date
    Mar 2006
    Posts
    1,475
    Rep Power
    15

    Default

    good reason not to upgrade is you can play iso's and ALL the homebrew not just the select bits that work with the gta loader if you want a web browser i would just try to find a homebrew one.

  4. #4
    contra24 is offline -Hacks Guru
    Join Date
    Dec 2005
    Location
    Middle East
    Posts
    1,691
    Rep Power
    15

    Default

    what the advantage of upgrading? to play these few games that arent working yet on 1.50?! well this is not enough reason, and 1.50 have a browser "fired up browser",
    also upgrading is a one way tract so be carefull

    try my 3.03OE-A installer here it\'s the best
    P.S DONT PM ME ASKING WHERE TO GET PS1 GAMES FROM

  5. #5
    kleimey is offline -Hacks Newbie
    Join Date
    Apr 2006
    Posts
    2
    Rep Power
    0

    Default

    what's the consensus on the "fired up browser"? will it run javascript, flash? what's the text input method like?

    I believe there are snes emulators that work on 2.0+. Am I wrong here? What about NesterJ or other nes emulators?

  6. #6
    dtjesus is offline -Hacks Neophyte
    Join Date
    Feb 2006
    Location
    The City Beneath The Surface
    Posts
    73
    Rep Power
    14

    Default

    Yeah you can use nester and the snes emulators on 2.0+ but they work better on 1.5. i think the fired up browser is good, but if you want to update for the browser, dont go higher than 2.0 cos u can always downgrade again.

  7. #7
    keedier is offline -Hacks Smarty
    Join Date
    Apr 2006
    Posts
    142
    Rep Power
    14

    Default

    a good reason not to upgrade is to convince sony that whatever they put on their latest upgrade, 1.5 users can too using homebrews and then maybe *just maybe* sony will decide to legalize homebrew....
    ------------------------------------------------------------------------------------------

    ------------------------------------------------------------------------------------------

  8. #8
    rin1276 is offline Senior Member -Hacks Veteran
    Join Date
    Dec 2005
    Location
    Puerto Rico
    Posts
    1,365
    Rep Power
    15

    Default

    Quote Originally Posted by dtjesus
    Yeah you can use nester and the snes emulators on 2.0+ but they work better on 1.5. i think the fired up browser is good, but if you want to update for the browser, dont go higher than 2.0 cos u can always downgrade again.
    Wise words, young grasshopper.........

    Genocide Music - Check out our music. Break away from the mainstream garbage.
    Download our ringtones for free, by logging on (through your cellphone) to www.tagtag.com/madhouse_pr

  9. #9
    psiko_scweek is offline -Hacks Neophyte
    Join Date
    Oct 2005
    Posts
    99
    Rep Power
    14

    Default

    Id say just stay with either 1.5 or 2.0 at least till a downgrader or full acess comes out for any other firmware versions. everyone is right, what can be made for the other versions of the FW can be re-created with homebrew on the 1.5.

    also, think of this, if say the PSX emulator gets released and it requires kernal mode for some reason, your SOL then. lol, the homebrew scene is getting better and better, and a lot of programmers are keeping things in user mode for the TIFF and GTA exploits, but if a killer app DOES get released on the PSP that requires 1.5...you may regret upgrading.

    anyways, 1.5s are getting harder to find, so save up your cash or just sell your 1.5 to someone who wnts a 1.5 and then buy yourself a 2.6
    Regards,
    Psiko Studios

  10. #10
    EMH
    EMH is offline -Hacks Smarty
    Join Date
    Jul 2005
    Posts
    185
    Rep Power
    15

    Default

    Lmao update if you want.

    Daxter iso works on 1.5, Syphon filter works on 1.5. All the good games works with 1.5. Only a few, dont work and I dont even know them cuz they are crap.

    And did you know that you can have the 2.0 browser with the MPH firmware launcher? Yes you can emulate the 2.0 firmware.

    I will keep 1.5 forever, there is no point in upgrading.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •