Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21

Thread: should I upgrade to 2.x ot stay 1.5 ?

  
  1. #1
    unk_now is offline -Hacks Newbie
    Join Date
    Jun 2006
    Posts
    3
    Rep Power
    0

    Default

    Hi there, I'm new here and to the PSP world.

    I have just acquired a PSP 1.52 which I could upgrade to 2.0 and downgrade to 1.5.

    I can now run many games using UMDLoader, but I bought Outrun2006 and I can't play it because it requires firmware 2.6.

    So I was wondering if I could upgrade my PSP, if so, up to WHICH version at the max, and which games will I still be able to play using UMDLoader or DevHook ?

    If I do that is there a chance that I can't run as many games as I can do now ?

    Thanks for your replies.


  2. #2
    killaj is offline Senior Member -Hacks Titan
    Join Date
    Nov 2005
    Location
    Daytona Beach
    Posts
    10,124
    Rep Power
    24

    Default

    DO NOT UPGRADE IT. you're on 1.5 . play some isos

  3. #3
    BeAkErOo's Avatar
    BeAkErOo is offline Senior Member -Hacks Titan
    Join Date
    Dec 2005
    Location
    Yellow Submarine
    Posts
    6,224
    Rep Power
    44

    Default

    hell yeah^^^^

    wait 4 outrun to be fixed, if u get a little bored play 100's of free isos
    3DS: 4167-4567-3684

  4. #4
    nekoakuma is offline -Hacks Hacker
    Join Date
    Apr 2006
    Location
    Australia
    Posts
    991
    Rep Power
    14

    Default

    or could wait for the kernal exploit (read around forums) to be fully unleashed. (yes, it's a beast waiting to get out)

    ..or if u want outrun, update n get a modchip. (highly not recommended)
    Launch PSP-1002 5.50 Prome-4 [Backup/Recovery PSP]
    Near-Launch PSP-1000 6.39ME-4 [Homebrew/iR controller]
    Near-Launch PSP-2002 5.50 Prome-4 [Games/Movies]

  5. #5
    BeAkErOo's Avatar
    BeAkErOo is offline Senior Member -Hacks Titan
    Join Date
    Dec 2005
    Location
    Yellow Submarine
    Posts
    6,224
    Rep Power
    44

    Default

    if he has a 1.5 then there is no need 2 wait for 2.5/6 kernel mode, he could use 1.5 and then if 4 some reason he wanted 2 go through tedious job of using gta exploit every time he wanted to play an iso he could upgrade(dont do it)
    3DS: 4167-4567-3684

  6. #6
    dienasty is offline -Hacks Guru
    Join Date
    May 2006
    Location
    graphic galaxy [Flare-Fx]
    Posts
    1,739
    Rep Power
    15

    Default

    Quote Originally Posted by unk_now
    Hi there, I'm new here and to the PSP world.

    I have just acquired a PSP 1.52 which I could upgrade to 2.0 and downgrade to 1.5.

    I can now run many games using UMDLoader, but I bought Outrun2006 and I can't play it because it requires firmware 2.6.

    So I was wondering if I could upgrade my PSP, if so, up to WHICH version at the max, and which games will I still be able to play using UMDLoader or DevHook ?

    If I do that is there a chance that I can't run as many games as I can do now ?

    Thanks for your replies.
    oh man do i feel bad for you cause im sure your achieng to play outrun but are pickled between upgrading or just playing your newly boughten game i hate situations like that ...

    ================ {~Flare-Fx~} ===============
    xX We Set The Trend.....We Set The Flare.....Flare-Fx Xx

  7. #7
    BeAkErOo's Avatar
    BeAkErOo is offline Senior Member -Hacks Titan
    Join Date
    Dec 2005
    Location
    Yellow Submarine
    Posts
    6,224
    Rep Power
    44

    Default

    i dont think there is any decision 2 be made, obviously u downgrade to 1.5
    3DS: 4167-4567-3684

  8. #8
    zhuki is offline -Hacks Neophyte
    Join Date
    Jan 2006
    Posts
    74
    Rep Power
    14

    Default

    stay with 1.5 m8 its worth it evry second :D

  9. #9
    unk_now is offline -Hacks Newbie
    Join Date
    Jun 2006
    Posts
    3
    Rep Power
    0

    Default

    Great, thanks for all your quick replies :)

    But with more and more games requiring firmware 2.5 and higher, at the end, some games may simply never work ?

    Or is there a chance that with time going, any game, whatever its firmware, can run on an 1.5 ?

  10. #10
    BeAkErOo's Avatar
    BeAkErOo is offline Senior Member -Hacks Titan
    Join Date
    Dec 2005
    Location
    Yellow Submarine
    Posts
    6,224
    Rep Power
    44

    Default

    all games will work with 1.5 eventually
    3DS: 4167-4567-3684

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •