Results 1 to 5 of 5

Thread: Opinions - Firmware 3.01

  
  1. #1
    fbdamn is offline -Hacks Newbie
    Join Date
    Mar 2007
    Posts
    3
    Rep Power
    0

    Default

    I'm about to buy an used PSP, and I want some advice from someone who knows all this firmware stuff, since I'm a PSP newbie.
    The info I got is that it was a 2.6 firmware, then it was changed to the 3.01 version, and the guy who is selling it says it runs games from the Memory Stick and emulators, etc., BUT it needs an original UMD to do so.
    What I need to know is: is this correct? Can I change/downgrade the firmware, so I don't need the UMD to run games from the Memory Stick?

    Thanks!


  2. #2
    burrito is offline -Hacks Ninja
    Join Date
    Oct 2006
    Posts
    679
    Rep Power
    13

    Default

    First you need to upgrade it to firmware 3.03.
    Then you need to find an unpatched version of Grand Theft Auto: Liberty City Stories. You will not be able to buy it new. It has to be used and check if its unpatched here: http://pspupdates.qj.net/How-to-find...g/49/aid/58178
    Then you can downgrade to 1.5 where you can run homebrew and games from your mem stick. Get the downgrader here, but you need the GTA: http://www.noobz.eu/joomla/index.php...temid=88888898

    If you can find a psp with firmware 2.80 or lower then you won't need to go through the trouble looking for unpatched GTA.
    Nobody cares about your PSP\'s firmware history.

  3. #3
    fbdamn is offline -Hacks Newbie
    Join Date
    Mar 2007
    Posts
    3
    Rep Power
    0

    Default

    So, the only way to "free" that PSP would be to find one of these unpatched GTA? If that's it, i'm out...
    The guy said that he is able to run games from the Memory Stick, using any original UMD. Is this really possible?

  4. #4
    burrito is offline -Hacks Ninja
    Join Date
    Oct 2006
    Posts
    679
    Rep Power
    13

    Default

    You need to downgrade to run games off the memory stick.
    Currently, 2.81 through 3.03 use a 3.03 downgrader that requires GTA. The only game that works is unpatched GTA: LCS.
    If the guy at the store lets you, check the firmware of some other used psps. If one has 2.80 or anything lower than that, you do not need GTA LCS to downgrade.

    Once you downgrade, you will not need a UMD in the psp to play UMD backups off the mem stick. But if you don't own the UMD that you are playing, that is illegal.
    Nobody cares about your PSP\'s firmware history.

  5. #5
    fbdamn is offline -Hacks Newbie
    Join Date
    Mar 2007
    Posts
    3
    Rep Power
    0

    Default

    So, that's it... I will have to look for another PSP. I just want to make sure that I will be able to do anything I want with my PSP, without any worries.
    Thanks for the info, taco111!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •