Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16

Thread: Best firmware currently?

  
  1. #1
    metalgod3082 is offline -Hacks Neophyte
    Join Date
    Oct 2006
    Posts
    83
    Rep Power
    13

    Default

    I have been out of the scene for awhile. Got a 1.5 firmware psp. What shd I upgrade it to?


  2. #2
    a'fiy is offline -Hacks Guru
    Join Date
    Dec 2006
    Location
    Singapore
    Posts
    2,307
    Rep Power
    15

    Default

    Cintro Download

    ::[Mr Nice Guy a.k.a Hafiy ::]

  3. #3
    TA-082_User is offline -Hacks Veteran
    Join Date
    Jan 2007
    Posts
    1,369
    Rep Power
    14

    Default

    Quote Originally Posted by Hafiy
    http://www.psp-hacks.com/forums/search.php?search_id=317984203

    31 pages long read it
    screw that. 3.03oe-c or 3.40oe-a

    your call. some people believe there is a flaw with 3.40, but I've had no problems yet.

  4. #4
    azatru is offline -Hacks Neophyte
    Join Date
    Apr 2007
    Location
    Portland, OR
    Posts
    60
    Rep Power
    13

    Default

    I totally agree with TA-082_User, either 3.03 OE-C, or 3.40 OE-A

    I personally prefer 3.40 OE-A, i have experienced NONE of the problems people have mentioned.

    I think most of it is because people dont understand this: RTFM

    read the f*cking manual

  5. #5
    PwarSknightsP is offline -Hacks Member
    Join Date
    Sep 2006
    Posts
    248
    Rep Power
    13

    Default

    3.03oe-c is known to be more "stable" while 3.40oe-a isn't; however I'm using 3.40oe-a and I didnt have any problems so far. Plus 3.40oe-a have more ps1 compatibility and future psp games may need 3.40 firmware(such as Bleach: HTS4 currently)

  6. #6
    TA-082_User is offline -Hacks Veteran
    Join Date
    Jan 2007
    Posts
    1,369
    Rep Power
    14

    Default

    Quote Originally Posted by PwarSknightsP
    3.03oe-c is known to be more "stable" while 3.40oe-a isn't; however I'm using 3.40oe-a and I didnt have any problems so far. Plus 3.40oe-a have more ps1 compatibility and future psp games may need 3.40 firmware(such as Bleach: HTS4 currently)
    Really? I thought games fw requirements were still lurking around the 2.81 - 3.11 area.

  7. #7
    dj2b4life is offline -Hacks Member
    Join Date
    Apr 2007
    Location
    Chino Hills
    Posts
    204
    Rep Power
    13

    Default

    Personally, I think 3.30 OE-A' is the most stable. Wouldn't go near 3.40 OE yet.

  8. #8
    shadowlaw is offline -Hacks Smarty
    Join Date
    Mar 2007
    Posts
    174
    Rep Power
    13

    Default

    3.4 oe is the best

    given that you dont have problem with it lol

    problem = just go back to older OE

  9. #9
    eloder is offline -Hacks Veteran
    Join Date
    Sep 2006
    Posts
    1,417
    Rep Power
    14

    Default

    i was ones on 3.03oe-c then upgraded to 3.40 oe but had problems so i downgraded back.... but when bleach came out, i had no choice but to upgrade to 3.40 oe then lucky i had experience no bug atm... :lol:

    in short, it's your decision... if you wanna play newer, high fw games then go for 3.40 oe :mrgreenthumbsup:

  10. #10
    PSPFANATICO is offline -Hacks Neophyte
    Join Date
    Apr 2007
    Posts
    71
    Rep Power
    13

    Default

    3.30 oe-a' no problems yet. Thinking of upgrading to 3.40 maybe

    PSPFANATICO

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •