Results 1 to 10 of 10

Thread: Wanting to purhase a psp

  
  1. #1
    dannyjjang is offline -Hacks Neophyte
    Join Date
    Jun 2007
    Posts
    69
    Rep Power
    13

    Default

    After 4 month of agony struggling if i were to buy a psp or ds lite i decided to buy a psp...yes 4month im a picky person when using money on electronics after all that research and my friends advice i chose to get a psp. Now about this firmware I see that i have to get the right one that get be upgraded to "oea?" version? im just wondering which "version" i should get , browsing over ebay i've seen psp already "oeaed" or a version 1.5 which can play emulators and etc?

    The reason im purchasing psp is the ps1 feature...i can't wait to play ff series in a portable device
    well thanks anyway guys and hope i can enjoy features in the future like you guys :)


  2. #2
    waldog is offline Senior Member -Hacks Monk
    Join Date
    Aug 2006
    Posts
    2,645
    Rep Power
    15

    Default

    Any 1.5 psp is ok, they can be updated to OE. A psp with OE is ok too.

  3. #3
    TA-082_User is offline -Hacks Veteran
    Join Date
    Jan 2007
    Posts
    1,369
    Rep Power
    14

    Default

    2.80 and below are downgradable. 2.81 through 3.03 are troublesome to downgrade, 3.10 + requires modchipping.

  4. #4
    waldog is offline Senior Member -Hacks Monk
    Join Date
    Aug 2006
    Posts
    2,645
    Rep Power
    15

    Default

    Quote Originally Posted by TA-082_User
    2.80 and below are downgradable. 2.81 through 3.03 are troublesome to downgrade, 3.10 + requires modchipping.
    2.81-3.03 are downgradable and are easy to downgrade as long as you have a GTA LCS 2.0 umd.

  5. #5
    dannyjjang is offline -Hacks Neophyte
    Join Date
    Jun 2007
    Posts
    69
    Rep Power
    13

    Default

    hmm okai so i should get a psp under 2.80
    http://cgi.ebay.com/Sony-PSP-1001K-G...QQcmdZViewItem

    this was a good deal eh? i wasnt sure waht to buy so miseed out

  6. #6
    waldog is offline Senior Member -Hacks Monk
    Join Date
    Aug 2006
    Posts
    2,645
    Rep Power
    15

    Default

    Quote Originally Posted by dannyjjang
    hmm okai so i should get a psp under 2.80
    http://cgi.ebay.com/Sony-PSP-1001K-G...QQcmdZViewItem

    this was a good deal eh? i wasnt sure waht to buy so miseed out
    Yes that's ok. But you can check stores in you area for a firmware that's easy to downgrade too. You don't have to use ebay.


    EDIT: Anything with that letter below 'O' is downgradable. The letter 'K' ones are 2.80 and below. The 'L' ones and above, require GTA LCS 2.0 UMD.



  7. #7
    killahcheese is offline -Hacks Veteran
    Join Date
    Jan 2007
    Location
    I love Coke
    Posts
    1,411
    Rep Power
    14

    Default

    You should definitely be extreamely cautious with ebay

    I bought one personally from there, looked all fine the guy had 100% on over 600 sales.
    the PSP i got had some problems internally in which PSP could not power up unless adaptor was in it.

    had to do walmart trick
    GOD BLESS WALMART

    ====
    better to deal with electronic stuff locally

    also make sure the person your buying from has tons of pictures of the item itself. Although this can't help too much, its better than just getting a standard picture of the PSP

  8. #8
    dannyjjang is offline -Hacks Neophyte
    Join Date
    Jun 2007
    Posts
    69
    Rep Power
    13

    Default

    errr thats true ebay is fishy i prefer buying it from sellers who has less sales powersellers are kinda fishy or i'll buy it from here or somewaht

  9. #9
    dannyjjang is offline -Hacks Neophyte
    Join Date
    Jun 2007
    Posts
    69
    Rep Power
    13

    Default

    Quote Originally Posted by waldog
    Quote Originally Posted by dannyjjang
    hmm okai so i should get a psp under 2.80
    http://cgi.ebay.com/Sony-PSP-1001K-G...QQcmdZViewItem

    this was a good deal eh? i wasnt sure waht to buy so miseed out
    Yes that's ok. But you can check stores in you area for a firmware that's easy to downgrade too. You don't have to use ebay.


    EDIT: Anything with that letter below 'O' is downgradable. The letter 'K' ones are 2.80 and below. The 'L' ones and above, require GTA LCS 2.0 UMD.


    http://i11.tinypic.com/6b0rq6t.jpg
    thx alot very help ful strange you need a GTA to downgrade? lol


    i have one more question with psp, you can also put psp games into the memory stick and play right?

  10. #10
    waldog is offline Senior Member -Hacks Monk
    Join Date
    Aug 2006
    Posts
    2,645
    Rep Power
    15

    Default

    Quote Originally Posted by dannyjjang
    thx alot very help ful strange you need a GTA to downgrade? lol


    i have one more question with psp, you can also put psp games into the memory stick and play right?
    Yes. The iso's run faster than umds too. Like load times.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •