Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: So im going through my old PS1 collection... Does FF7 work yet?

  
  1. #1
    Vistrix is offline -Hacks Neophyte
    Join Date
    Jan 2007
    Posts
    92
    Rep Power
    13

    Default

    I remember reading FF7-FF9 issues with the PSP.

    Is FF7, 8 & 9 100% compatible with 3.4OE yet? I want to start playing these on my PSP but I don't want it to stop working at a certain point.


  2. #2
    AliasXZ is offline -Hacks Smarty
    Join Date
    Jan 2007
    Location
    Huddersfield, England
    Posts
    105
    Rep Power
    13

    Default

    my ff's are PAL and only ff7 works

    I believe ff 7, 8 and 9 in NTSC format are ok, but if you use PAL versions, you change the game ID in popstation to SLPS01222 to make em work

    I cant test the above because I run 330 not 340
    Gentoo Linux user :-)
    Clear PSP
    -----------
    NO TA-802 > FW 2.71 < 1.50 w DevH 3.11 > 3.10OE-A2 > 3.30OEA\' < 3.10OE-A2 > 3.30OEA\'

  3. #3
    Vistrix is offline -Hacks Neophyte
    Join Date
    Jan 2007
    Posts
    92
    Rep Power
    13

    Default

    Ah damn...I have the PAL versions.

    So does that ID change it to NTSC or something? It already sounds like it would cause problems lol

  4. #4
    oOSeY is offline -Hacks Monk
    Join Date
    Oct 2006
    Location
    DAX Country
    Posts
    2,806
    Rep Power
    15

    Default

    i don't think it matters.. are you using zinga's popstation?

    it's ff8 just a complete pain in the ass.. :paranoid:

    :Need help? Click here first.

  5. #5
    SkyDX's Avatar
    SkyDX is offline -Hacks Ninja
    Join Date
    Aug 2006
    Posts
    730
    Rep Power
    13

    Default

    I'm in Lindblum right now on FF9 and had no problems with 3.40OE-A so far.

    XBOX Live ID: SkyyX | Wii Friend Code: 3148-9988-9956-8604

  6. #6
    Klax's Avatar
    Klax is offline -Hacks Enthusiast
    Join Date
    Apr 2007
    Location
    Bayside, NY
    Posts
    398
    Rep Power
    13

    Default

    I know that 3.40 fixed some game crashes like RE2. All you have to do is change the game id, and it should prolly work.

    Pooky_187: Downloading wouldn't be faster than downloading <--Fail
    XBL: I Klax I | PSN: I-Klax-I

  7. #7
    Lil Peel's Avatar
    Lil Peel is offline -Hacks Enthusiast
    Join Date
    Jan 2007
    Posts
    583
    Rep Power
    13

    Default

    or alternatively download the NTSC version as some PAL games don't work properly
    4Chans most epic fail quote:
    "This is what I do when I see a 360. I turn 360 DEGREES and walk away"
    PS3 ID/gamertag - LilPeel

  8. #8
    highwindscloud is offline -Hacks Enthusiast
    Join Date
    May 2007
    Location
    New York,NY
    Posts
    315
    Rep Power
    13

    Default

    i've used ff9 on 3.03 oe c and from what i played it was fine. it was a lil laggy in the world map but thats about it
    I can't stop coming!

  9. #9
    freebeer187 is offline -Hacks Ninja
    Join Date
    Mar 2007
    Posts
    650
    Rep Power
    13

    Default

    ff7 works 100% if you make the image an .iso on 3.03 oec

  10. #10
    spacewiz's Avatar
    spacewiz is offline -Hacks Veteran
    Join Date
    Feb 2007
    Location
    behind a ps3
    Posts
    1,402
    Rep Power
    14

    Default

    the only game that is still having trouble is FF8. you have to use the biohazard2 game id. but even then the game still suffers from what i hear, major slow downs, but no longer crashes. i don't know if its been improved apon beacuse i havne't heard anything about since the fix came out.
    PS3 : 300gb : 4.41 OFW
    PSP-1000 : 6.60 PRO-C Fix 3
    DSi : acekard2i - AKAIO 1.8.9

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •