Results 1 to 2 of 2

Thread: Final Fantasy - Crisis Core needed PSP Update

  
  1. #1
    ProudToBeDead is offline -Hacks Neophyte
    Join Date
    Nov 2007
    Posts
    82
    Rep Power
    12

    Default

    Sorry, but I had no clue for a better subject.

    The queston is: my psp is at 3.71 m33-3 but when Crisis Core comes out next year which firmware would it need?
    I know, that you can't know this by now but just guess.
    I would have to go back to original firmware if Crisis Core wouln't run with 3.71 m33-3.

    which firmware does the japanese Crisis Core need?

    PSP Sllim & Lite, 3.90 m33-3 & Popsloader V2

  2. #2
    replicat0r is offline -Hacks Veteran
    Join Date
    May 2007
    Posts
    1,140
    Rep Power
    14

    Default

    i think, jap version only needs 3.52... not 2 sure, lol but i dont think it would requre more then 3.71... unless sony tries 2 fuck with us.. again.. but there is always pandora battery
    PSP phatty: 1.5---->2.71---->3.03oe-c---->semi brick---->3.51 m33----> 3.52 m33---> $140
    PSP slim: 3.60----------------------------------------------->3.71 m33----> 3.71 m33-2
    <---woot! finally its done!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •