Results 1 to 6 of 6

Thread: Need a new PSP, which one to buy? Advice needed

  
  1. #1
    megman6 is offline -Hacks Smarty
    Join Date
    Sep 2006
    Posts
    121
    Rep Power
    13

    Default Need a new PSP, which one to buy? Advice needed

    I own a PHAT PSP at the moment. The X button is wearing down. It doesn't have that "bounce" feel any more. So I am thinking of buying a new PSP. However, I don't know which one to get as there's slim2000 & slim3000. I have not been keeping up with PSP for a while since PHAT works great with all ISO & Custom FM. I know the PHAT had different boards. Can someone here help me out? Can I install custom FM on slime2000 & slim3000? I came across some reading that slim3000 is not hackable with the newer firmware? Thanks in advance.


  2. #2
    megman6 is offline -Hacks Smarty
    Join Date
    Sep 2006
    Posts
    121
    Rep Power
    13

    Default

    Found my own answer. It seems like slim2000 is hackable for FW4.01 & below and this applies to both board revision of TA-088v3 or TA-090. higher firmware than 4.01 may be hackable in near future due to the new tiff exploid. psp3000 is not hackable, period. This sounds about right?

  3. #3
    Mick is offline Coma -Hacks Titan
    Join Date
    Feb 2007
    Location
    Canada
    Posts
    4,460
    Rep Power
    0

    Default

    if the psp comes with 4.01 or higher outa the box then its unhackable via pandora. use ChickHEN to get cfw on them. 3000's can only run homebrew

  4. #4
    wh1tef@ng is offline -Hacks Titan
    Join Date
    Mar 2008
    Location
    hell!!
    Posts
    3,983
    Rep Power
    15

    Default

    Quote Originally Posted by megman6 View Post
    Found my own answer. It seems like slim2000 is hackable for FW4.01 & below and this applies to both board revision of TA-088v3 or TA-090. higher firmware than 4.01 may be hackable in near future due to the new tiff exploid. psp3000 is not hackable, period. This sounds about right?
    its not 4.01 and below... it shud be 3.95 and below
    3 necessary things to do to be fit everyday
    Sleep
    Eat
    Xercise

  5. #5
    megman6 is offline -Hacks Smarty
    Join Date
    Sep 2006
    Posts
    121
    Rep Power
    13

    Default

    Correct. 3.95 & below is ok.

    So if slim 2000 comes with 4.01 an up, I can still install custom FW with ChickHen and then play ISO? So sounds like PSP3000 is the one not to get but any slim2000 should be ok to by and install custom FW & play ISO games?

  6. #6
    PSP-BELLA's Avatar
    PSP-BELLA is offline -Hacks Enthusiast
    Join Date
    Jun 2009
    Posts
    300
    Rep Power
    11

    Default

    i myself have the same problem, i like being up to date, so i think of getting the new PSP-3000.. and think it will be hackable later on .. but who knows !!

    so i am a bit confused too

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •