Sorry guys, I have no knowledge at all about the PSP CFW, I’ve bought my PSP with the 3.90 M33-3 installed already, now I just bought the UMD of the GT5 and it asks to update it to 5.55, I’ve seem a lot of comments that the internet will not work with this 5.50 Gen-D-full and I would lost as well the Skype utility (for me it’s important to have it), does anyone could help me to clarify those topics are real or not? And would be great as well to have a tutorial do upgrade from this 3.90 M33-3 to this 5.50 Gen-D-full, thank you in advance.