Results 1 to 10 of 10

Thread: Best PSP firmware to be on?

  
  1. #1
    mk92595's Avatar
    mk92595 is offline -Hacks Smarty
    Join Date
    Mar 2011
    Posts
    172
    Rep Power
    10

    Smile Best PSP firmware to be on?

    I have 2 PSP's one is a 3001 with 5.03 gen-c and the other one is a 1001 at 5.00 m33-6.

    Whats the best firmware to be on for each PSP?


  2. #2
    Vallard's Avatar
    Vallard is offline -Hacks Newbie
    Join Date
    Dec 2010
    Location
    Japan
    Posts
    33
    Rep Power
    9

    Default

    IMO

    1k/2k(old MOBO) = 5.00 M33
    2k('new' MOBO)/3k(3g) = 5.03 Prome-4(3)
    3k(4g)/GO = 6.20 TN-D

    I actually have a PSP3k(3g), with 5.03 prome-4, works 100% with all game that I tested, no lag, no crashes, fast and good. =P

  3. #3
    Cheesetheif's Avatar
    Cheesetheif is offline Senior Member -Hacks Monk
    Join Date
    Jul 2009
    Location
    Amerika
    Posts
    2,603
    Rep Power
    14

    Default

    Quote Originally Posted by Vallard View Post
    1k/2k(old MOBO) = 5.00 Prometheus 4
    2k('new' MOBO)/3k(3g) = 5.03 Prome-4(3)
    3k(4g)/GO = 6.20 TN-D OR 6.35 Pro-B3
    Corrected.

    5.00 Prometheus 4 is M33-6, but patched to play new games. All of the old capabilities are kept.

    As for 3k's (4g+) and Go's, 6.35 is not a bad choice either. It is a CFW instead of a hen, so it includes isoloaders installed into the CFW, no need for prometheus ISO loader or making "shortcuts" with ISOtool. That said though, 6.20 TN-D is the only one that can be made permanent.

    UnŽestŽiŠted™

  4. #4
    mk92595's Avatar
    mk92595 is offline -Hacks Smarty
    Join Date
    Mar 2011
    Posts
    172
    Rep Power
    10

    Default

    My PSP 3000 ( I think 3g) is on 5.03 gen-c, If i upgrade to 6.20 TN-D will it be permanent?

    and is it a cfw or a hen?

  5. #5
    ifrit05's Avatar
    ifrit05 is offline -Hacks Veteran
    Join Date
    Feb 2011
    Location
    Wyandotte, MI USA
    Posts
    1,047
    Rep Power
    10

    Default

    If you download the Perm patch, then yes, it will be perm. Else it's just a temp. HEN.
    PSP-1001 6.39 ME-8 | PS3 CECH-2501B REBUG 4.70.1

  6. #6
    mk92595's Avatar
    mk92595 is offline -Hacks Smarty
    Join Date
    Mar 2011
    Posts
    172
    Rep Power
    10

    Default

    so no iso or psx support?

  7. #7
    xocomaox's Avatar
    xocomaox is offline -Hacks Ninja
    Join Date
    Aug 2010
    Location
    ヘルプデスク
    Posts
    664
    Rep Power
    9

    Default

    Quote Originally Posted by Cheesetheif View Post
    5.00 Prometheus 4 is M33-6, but patched to play new games. All of the old capabilities are kept.
    i don't see the point of taking 5.00 to prome-4 when all the newest games work with just regular 5.00 m33-6. and sometimes older games which have been pre-patched don't work right with prome-4.

    best to stick with 5.00 m33-6.
    currently playing
    テイルズ オブ リバース
    ToP: なりきりダンジョン X (0.11)
    psp-1001 5.00 m33-6

  8. #8
    Cheesetheif's Avatar
    Cheesetheif is offline Senior Member -Hacks Monk
    Join Date
    Jul 2009
    Location
    Amerika
    Posts
    2,603
    Rep Power
    14

    Default

    Quote Originally Posted by xocomaox View Post
    i don't see the point of taking 5.00 to prome-4 when all the newest games work with just regular 5.00 m33-6. and sometimes older games which have been pre-patched don't work right with prome-4.

    best to stick with 5.00 m33-6.
    What are you on? New games don't work with 5.00 M33-6 unless they are manually patched or are pre-patched. In either case, you cannot play UMD games because you cannot change files on the disc. Also, why use pre-patched games, just use a clean copy.

    As for 6.20 TN-D, it is a hen, but it has PSX support. With Prometheus ISO loader you can load ISO's.

    UnŽestŽiŠted™

  9. #9
    xocomaox's Avatar
    xocomaox is offline -Hacks Ninja
    Join Date
    Aug 2010
    Location
    ヘルプデスク
    Posts
    664
    Rep Power
    9

    Default

    Quote Originally Posted by Cheesetheif View Post
    What are you on? New games don't work with 5.00 M33-6 unless they are manually patched or are pre-patched. In either case, you cannot play UMD games because you cannot change files on the disc. Also, why use pre-patched games, just use a clean copy.
    plugins my friend.
    currently playing
    テイルズ オブ リバース
    ToP: なりきりダンジョン X (0.11)
    psp-1001 5.00 m33-6

  10. #10
    Cheesetheif's Avatar
    Cheesetheif is offline Senior Member -Hacks Monk
    Join Date
    Jul 2009
    Location
    Amerika
    Posts
    2,603
    Rep Power
    14

    Default

    Quote Originally Posted by xocomaox View Post
    plugins my friend.
    I hate having too many plugins active and I am sure others do too. Remember, they can interfere with one another.

    UnŽestŽiŠted™

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •