Results 1 to 10 of 10

Thread: Soft Subtitle for PSP

  
  1. #1
    Yawa's Avatar
    Yawa is offline -Hacks Newbie
    Join Date
    Jul 2009
    Posts
    43
    Rep Power
    10

    Default Soft Subtitle for PSP

    I was able to successfully add two audio stream under mp4 container using Handbrake apps but sadly adding srt subtitle troubles me. The subtitle appears in my PC video player but it won't show under the built it player for PSP. I can switch between the two audio but nothing detected in the subtitle icon. I think the subtitle only works if using UMD videos but I guess there might be an alternative way to add a soft subtitle for mp4 container.

    PSP-2006 Ta088v3 2g 5.03 ChickHEN R2 > CFWEnabler 3.70 > 5.03 kxploit > 5.03 MHU > 6.20 PRO-B6

  2. #2
    Rob S.'s Avatar
    Rob S. is offline Senior Member -Hacks Titan
    Join Date
    Jan 2006
    Location
    41° 11' 3" N / 73° 8' 1" W
    Posts
    7,695
    Rep Power
    50524

    Default

    Quote Originally Posted by Yawa View Post
    I think the subtitle only works if using UMD videos
    Correct.

    The PSP's video player subtitle function will only work if it's a UMD Video or a UMD Video dumped to ISO.

    Quote Originally Posted by Yawa
    I guess there might be an alternative way to add a soft subtitle for mp4 container.

    Use a homebrew video player such as PMPlayer Advance which supports SubRip (.srt) & MicroDVD (.sub):

    http://cooleyes.fx-world.org/documentation.html

  3. #3
    Yawa's Avatar
    Yawa is offline -Hacks Newbie
    Join Date
    Jul 2009
    Posts
    43
    Rep Power
    10

    Default

    Thanks Rob for the link I was able to setup PMPlayer with sub I didnt know we need to edit something manually for the sub to display. But PMPlayer has some kind a problem playing with two audios but it plays fine in the built-in player. I have no choice but to use the hardsub method.

    Anyways I'm still hoping that someone can fool the built-in player for thinking an ordinary video media file like UMD Video disc to enable the subtitle feature.
    PSP-2006 Ta088v3 2g 5.03 ChickHEN R2 > CFWEnabler 3.70 > 5.03 kxploit > 5.03 MHU > 6.20 PRO-B6

  4. #4
    ZiNgABuRgA's Avatar
    ZiNgABuRgA is offline Senior Member -Hacks Titan
    Join Date
    Sep 2006
    Location
    4CHIN
    Posts
    11,044
    Rep Power
    25

    Default

    It's not that simple. The PSP doesn't support any standard subtitle format I believe.

    For PPA, you need to figure out the key combinations to switch audio and turn subs on/off.
    I find that the fonts don't look terribly good on PPA though, so I prefer hardsubbing.

  5. #5
    Yawa's Avatar
    Yawa is offline -Hacks Newbie
    Join Date
    Jul 2009
    Posts
    43
    Rep Power
    10

    Default

    In PPA to turn on/off sub just Hold X + L Trigger. Try Tahoma for font, mine look great.

    Can we make an ordinary video file into UMD Video then turn into ISO?
    PSP-2006 Ta088v3 2g 5.03 ChickHEN R2 > CFWEnabler 3.70 > 5.03 kxploit > 5.03 MHU > 6.20 PRO-B6

  6. #6
    ZiNgABuRgA's Avatar
    ZiNgABuRgA is offline Senior Member -Hacks Titan
    Join Date
    Sep 2006
    Location
    4CHIN
    Posts
    11,044
    Rep Power
    25

    Default

    People have constructed custom UMD Video ISOs, but it's not an easy process, and I'm not sure if anyone's actually gotten soft subtitles to work anyway.

  7. #7
    Yawa's Avatar
    Yawa is offline -Hacks Newbie
    Join Date
    Jul 2009
    Posts
    43
    Rep Power
    10

    Default

    I just found out that PMPlayer will out of sync with the audio after playing it for long time.
    PSP-2006 Ta088v3 2g 5.03 ChickHEN R2 > CFWEnabler 3.70 > 5.03 kxploit > 5.03 MHU > 6.20 PRO-B6

  8. #8
    ZiNgABuRgA's Avatar
    ZiNgABuRgA is offline Senior Member -Hacks Titan
    Join Date
    Sep 2006
    Location
    4CHIN
    Posts
    11,044
    Rep Power
    25

    Default

    It shouldn't. Make sure you've converted your files correctly - in particular, your video is running at the correct framerate.
    I've watched 2 hour videos with PPA without sync issues.

  9. #9
    Yawa's Avatar
    Yawa is offline -Hacks Newbie
    Join Date
    Jul 2009
    Posts
    43
    Rep Power
    10

    Default

    Yeah I guess PPA does not like some of my H264 compression setting. I don't have any Sync problem with the built it.

    By the way how many times did Sony improve the built in player since v3.xx to v6.xx?
    PSP-2006 Ta088v3 2g 5.03 ChickHEN R2 > CFWEnabler 3.70 > 5.03 kxploit > 5.03 MHU > 6.20 PRO-B6

  10. #10
    ZiNgABuRgA's Avatar
    ZiNgABuRgA is offline Senior Member -Hacks Titan
    Join Date
    Sep 2006
    Location
    4CHIN
    Posts
    11,044
    Rep Power
    25

    Default

    Just make sure the framerate is right. Other settings shouldn't matter.

    From 3.30 to 6.60, pretty much nothing - they've added a few control features like scene selection etc, but nothing major.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •