While Singstar takes you back to the 80s, Descrambler is taking that back to when a firmware version was easily hacked -- firmware version 3.41 and 3.55. Singstar, if you don't know, requires firmware 3.70 or later and thanks to Descrambler, who has descrambled the bits and bytes, has released a patch for said game on said hacked firmwares. The download and all that is explained below.
read more




More...