Hey all,
I'm not very knowledgeable when it comes to stuff like this. I have a PSP with cfw 3.52 M33-4. It works fine and I'm very happy until recently I discovered I can't play newer games. Newer games will attempt to install a new firmware and won't play without doing so. I can't get around this.

I tried copying the UMD and then running the ISO off the machine but I get an error message (the game in question is Motorstorm Arctic Edge) the error just says the game could not be started (80020148). Running the UMD itself will just end up with the game wanting to update the firmware.

I also tried downloading a plugin, PSNlover, but I couldn't get it to work.

How else could I get around this?