Results 1 to 2 of 2

Thread: PIC0 is not shown

  
  1. #1
    Fosco Corazza is offline -Hacks Newbie
    Join Date
    May 2014
    Posts
    2
    Rep Power
    0

    Default PIC0 is not shown

    Hi, I'm programming a project for PSP with OSLIB libraries, and I got a little problem. The PIC0.png, the image that should be shown on the right of the icon on the home, is ignored, while PIC1.png and ICON0.png are visible.




    I put them in the folder "pspPreview" of my project and named PIC0, PIC1 and ICON0 (all .png). My makefile is this:


    Code:
    TARGET = otop_tsp
    OBJS = main . o
    
    INCDIR = 
    CFLAGS = -G4 -Wall -O2 
    CXXFLAGS = $(CFLAGS) -fno-exceptions -fno-rtti
    ASFLAGS = $(CFLAGS)
    
    LIBDIR =
    LDFLAGS =
    STDLIBS= -losl -lpng -lz \
    		-lpspsdk -lpspctrl -lpspumd -lpsprtc -lpsppower -lpspgu -lpspaudiolib -lpspaudio -lm
    LIBS=$(STDLIBS)$(YOURLIBS)
    
    
    EXTRA_TARGETS = EBOOT . PBP
    PSP_EBOOT_TITLE = The Scarlet Professor
    PSP_EBOOT_ICON = pspPreview/ICON0 . png
    PSP_EBOOT_PIC0 = pspPreview/PIC0 . png
    PSP_EBOOT_PIC1 = pspPreview/PIC1 . png
    
    PSPSDK=$(shell psp-config --pspsdk-path)
    include $(PSPSDK)/lib/build . mak
    (Of course ICON0 . png and all the other dot have no spaces, being actually ICON0.png, but if I put dots with no spaces this forums thinks they are links and I can't post. Just replace " . " with ".")

    But PIC0 is not visible while PIC1 and ICON0 are.


    I tried to use not a folder, use upper and lower case filename, change sizes (480x272, 310x180, 8bit/Channel - which works for PIC1) but it never works. I noticed that when I compile on the Command Shell, the text presented is this:

    Code:
    pack-pbp EBOOT . PBP PARAM . SFO pspPreview/ICON0 . png  \
                    NULL NULL pspPreview/PIC1 . png  \
                    NULL  otop_tsp_strip . elf NULL
    Not showing PIC0. Finally, I don't know if this help, but when I require the "signature" of the pack-pbp command it says this:

    Code:
    USAGE: pack-pbp <output . pbp> <param . sfo> <icon . png> <icon1 . pmf> <unknown . png> 
    <pic1 . png> <snd0 . at3> <unknown . psp> <unknown . psar>
    and where there should be the pic0 file it writes <unknown . png>


    What am I doing wrong? Thank you very much and sorry for my terrible english!


  2. #2
    Fosco Corazza is offline -Hacks Newbie
    Join Date
    May 2014
    Posts
    2
    Rep Power
    0

    Default

    Up?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •