Results 1 to 5 of 5

Thread: 1 RL and Error 64

  
  1. #1
    imported_theoutlaw is offline -Hacks Newbie
    Join Date
    Sep 2010
    Posts
    2
    Rep Power
    0

    Default

    My sons xbox360 has just had its first red ring appear in the bottom right hand corner, the error code that comes on the screen is ERROR 64.

    Its about 2-1/2 years old and NOT been hacked/modded in anyway.

    Is it done for or is there hope(or at least a reasonably priced hope)!

    many thanks


  2. #2
    ERIFNOMI is offline oops -Hacks Titan
    Join Date
    Apr 2007
    Posts
    4,384
    Rep Power
    0

    Default

    That is a DVD drive error. Maybe the drive is dead.

  3. #3
    Powerslave is offline Gone fishin -Hacks Titan
    Join Date
    Apr 2006
    Posts
    7,900
    Rep Power
    0

    Default

    http://www.xbox360-hacks.com/forums/...ic.php?id=2099

    Nice convenient thread there, all ready to be read and processed by your brain...

    64 - DVD drive timed out during reset - Comes up after the M$ Start up Screen - HDD Drive Issue? Remove and reconnect HDD. Also said to be a DVD drive invalid Key or Firmware issue. If you got this after a flash, then that would be the case, reflash with original firmware & key.

    $125.00 for a send back, may as well buy another USED console for => 80.00, not worth the repair costs anymore.

  4. #4
    imported_theoutlaw is offline -Hacks Newbie
    Join Date
    Sep 2010
    Posts
    2
    Rep Power
    0

    Default

    Oops my bad, sorry i did search for answers but musta gave up before i got to that one :)


    I havent flashed or done anything anything to the xbox.

    I think it may be the dvd-drive as theres a disc inside and i cant open the tray either.

  5. #5
    Powerslave is offline Gone fishin -Hacks Titan
    Join Date
    Apr 2006
    Posts
    7,900
    Rep Power
    0

    Default

    I have THREE XB360 consoles I may be selling, all with 20Gb HDDS... I can get $120.00 for them easy, they're all in excellent condition. I really don't need all this hardware anymore...

    If it does not open with the BUTTON, try the option from the dashboard, I think you press (X) to eject, something like that. I had a box where the button was not working, or so I thought, it was just the ARM to the button. The thing you press for eject, is NOT the button itself. The button is on the motherboard, and that has an ARM that extends down to press the button when you press the eject piece...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •